Vodafone GT 3G+ EMEA with Ubuntu 5.10

Victory, after searching the web for about 2 weeks for HOWTO’s to install the vodafone gt 3g+ card with ubuntu for using in austria,I did it at the end. This should be a step by step description of what has to be done to get it work. This HowTo is for all user who have the vodafone model which does not register as usb devices. This type of card registers as pci device.

For details on how to get the thing working, see the attached files. For the content and functionality in the attached scripts I will take no responsibility for any harm and damage done to your system. I advise you to review the scripts before using them. Preconditions for the automatic activation script are:

  1. nozomi module (download and make, described in howto)
  2. kppp (sudo apt-get install kppp)
  3. zenity (sudo apt-get install zenity)

Resources:

Note:

Pleas run the activateVodafoneCard script with sudo, else it would not work correctly. So long and have fun 😉

Advertisements

9 Gedanken zu “Vodafone GT 3G+ EMEA with Ubuntu 5.10

  1. After upgrading to 6.06 LTS the module nozomi needed for the vodafone card did not work any more. I had the install the build-essentials package, the new kernel sources and the new kernel headers by issuing:

    sudo apt-get install build-essentials linux-headers-`uname -r` linux-source-2.6.15

    After that change to the directory /lib/modules/`uname -r` and add a symbolic link to your kernel header sources: ln -s /usr/src/linux-headers-`uname -r` build

    Change back to the nozomi source directory and call: sudo make. Copy the module to the above mentionen locations and perform an insmod.

    Fine again 😉

  2. Thank’s a lot for your work !! It worked flawlessly on a IBM T41 with both Ubuntu 5.10 and 6.06

    If someone wants to use this card with T-Mobile then please use phone number *99# instead and any user/password. Both user and password set to x worked fine for me.

  3. Just a small correction on the apt-get command. It’s essential (singular)

    sudo apt-get install build-essential linux-headers-`uname -r` linux-source-2.6.15

    Thanks a lot for your article,
    Julian

  4. Pingback: foto sesso

  5. I am trying to get my Vodafone 3G card running on my IBM T41 but sofar no succes, also not with the Lenovo Download.

    Thoes any one has a standard web link to download the right data ?

    Thanx, John

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s